RouterOS之DDNS(动态域名)

By | 2018年11月18日16:45:52

新版ROS的IP菜单下有个Cloud,其实就是支持动态域名的,将此功能使能后,过一会儿就Public Address和DNS Name中就会显示出内容,前都为你的外网IP地址,后者为自动创建域名,以后使用这个域名访问就行了。

如果要使用国内的DDNS服务,如花生壳(xxx.wicp.net)或pubyun(xxx.f3322.net),则需要使用脚本程序了。创建脚本:System–>Scripts–>新建(就是那个+号),在对话框中的Name项输入DDNS,把所用的复选框打上构,下面的文本框是用来输出脚本程序的。以下是f3322.net的DDNS更新IP的脚本程序(测试OK),根据自己的情况修改红色加粗的内容,uuu表示动态域名的用户名,ppp表示动态域名的密码,xxx表示动态域名名称,pppoe-out表示拔号连接的名称。

:local ednsuser “uuu”
:local ednspass “ppp”
:local ednshost “xxx.f3322.net”
:local ednsinterface “pppoe-out”
:local members “http://members.3322.net/dyndns/update?system=dyndns”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost;
}
}

此脚本程序的工作内容:检查当前的IP地址和域名xxx.f3322.net指向的IP是否相同,如果不同则向动态域名服务器提交请求更新IP。

脚本程序编写好后,需要定时运行,因此需要创建一个计划任务:System–>Scheduler–>新建(就是那个+号),将对话框中的Interval设置为:00:01:00,表示1分钟执行一次,在On Event文本框中输入DDNS,其它的默认值即可。

另外要注意,如果电信拔号上网分配到的IP是100.开头的,则意味着你是通过电信的内网NAT上网的,没有直接连到外网,无法通过端口映射实现外网访问内部的服务器。那就打个电话给电信客户要求使用外网IP即可。

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注